sree4
Cadet
Cadet
  • 287 Views

Ansible Automation hub install fails at TASK [pulp.pulp_installer.pulp_common : Install the Pulp und

TASK [pulp.pulp_installer.pulp_common : Install the Pulp undeclared dnf package dependencies] ***
fatal: [10.8.31.149]: FAILED! => {"changed": false, "failures": [], "msg": "Depsolve Error occurred: \n Problem: conflicting requests\n - nothing provides selinux-policy >= 3.14.3-67.el8_4.2 needed by pulpcore-selinux-1.2.6-2.el8pc.x86_64", "rc": 1, "results": []}

 

 

Anyone see this error? I am trying to set up automation hub on redhat 8.4 version.

Thanks

Labels (1)
0 Kudos
2 Replies
Sillihkram
Flight Engineer
Flight Engineer
  • 67 Views

It's installable from the baseOS repo, perhaps it is not available on your system?

$ lsb_release -d
Description: Red Hat Enterprise Linux release 8.4 (Ootpa)

$ sudo dnf list selinux-policy
Updating Subscription Management repositories.
Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 130 kB/s | 4.1 kB 00:00
Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs) 144 kB/s | 4.5 kB 00:00

Installed Packages
selinux-policy.noarch 3.14.3-67.el8_4.2 @RHEL-8-for-x86_64-baseos-rpms


0 Kudos
bonnevil
Starfighter Starfighter
Starfighter
  • 43 Views

I think we hit this in testing for Training development too, and basically the workaround is to install that missing RPM and try again.  Luckily, setup.sh drives Ansible playbooks and can be re-run after a failure if you want to try again (and in fact that's basically how you have to add more nodes to automation mesh right now).

0 Kudos
Join the discussion
You must log in to join this conversation.