Eduardo6
Mission Specialist
Mission Specialist
  • 731 Views

DO180 - Errors with lab exercises

Jump to solution

I am getting the following error in the lab environment for DO180
Red Hat OpenShift Administration I: Operating a Production Cluster (DO180) v4.14

This started happening today.
- I have tried to do other previous exercises that I had already done, and the result is the same.
- I have deleted the lab environment and created it again, and the error persists.
- I also tried canceling the Course subscription and resubscribing, but the error persists.

Maybe I'm doing something wrong, but I can't find a way to continue.

Eduardo6_0-1718941669553.png

image.png

Labels (4)
1 Solution

Accepted Solutions
Chetan_Tiwary_
Moderator
Moderator
  • 595 Views

Hello @Eduardo6 @cdelfly @JohnDeeBee @MrChapeauRouge @Radek_Klewin !

Regret the incovenience caused, there was a glitch which was resolved sometimes back today - please rebuild your labs and you should be good to proceed with the course.

View solution in original post

11 Replies
  • 521 Views

I have the same problem with DO280 labs.

  • 510 Views

same in DO180.  I stopped and restarted Lab environment and issue persists

"Could not find modules for course do180"

  • 499 Views

Looks like a general issue because I'm facing the same for course DO316. Deleting and rebuilding the environment doesn't help.

I also tried the command "lab install gl006" as suggested by the error message but it's also failing.

JohnDeeBee_0-1718960725948.png

 

0 Kudos
cdelfly
Mission Specialist
Mission Specialist
  • 497 Views

Try older version of lab, it works for me until it is fixed on version 4.14

0 Kudos
cdelfly
Mission Specialist
Mission Specialist
  • 500 Views

Same issue as Labs don't work - Red Hat Learning Community it seems to be an error only with version 4.14 of lab so you can try with an older version

Eduardo6
Mission Specialist
Mission Specialist
  • 419 Views

Everyone, I have a Support Request for this issues.

Eduardo6_0-1718986443130.png

 

With details:
- course name and course code: Red Hat OpenShift I: Containers & Kubernetes (DO180) v4.14
- course version: v4.14
- chapter number: Chapter 3. Run Applications as Containers and Pods
- section number: Guided Exercise: Create Linux Containers and Kubernetes Pods
- step number in guided exercise or lab:

As the student user on the workstation machine, use the lab command to prepare your system for this exercise.

This command ensures that all resources are available for this exercise.

[student@workstation ~]$ lab start pods-containers

URL: https://rol.redhat.com/rol/app/courses/do180-4.14/pages/ch03s02


OUTPUT:
[student@workstation ~]$ lab start pods-container
Could not find modules for course gl006
CRITICAL: root:Traceback (most recent call last):

File "/home/student/.venv/labs/lib/python3.9/site-packages/labs/labload.py", line 26, in loadcache
module= importlib.import_module(course)
File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import(name [level:], package, level)
File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
File "<frozen importlib._bootstrap>", line 984, in _find_and_load_unlocked
ModuleNotFoundError: No module named 'gl006'

Could not find modules for course gl006
CRITICAL: root: Traceback (most recent call last):
File "/home/student/.venv/labs/lib/python3.9/site-packages/labs/labload.py", line 26, in loadcache module= importlib.import_module(course)
File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import (name [level:], package, level)
File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
File "<frozen importlib._bootstrap>", line 984, in _find_and_load_unlocked
ModuleNotFoundError: No module named 'gl006'
ERROR: root: Lab script has failed due to a LabError: Script pods-container not in course library gl006 Traceback (most recent call last):
File "/home/student/.venv/labs/lib/python3.9/site-packages/labs/lab.py", line 233, in start
grading labload.import_grading_library(config, script)
File "/home/student/.venv/labs/lib/python3.9/site-packages/labs/labload.py", line 130, in import_grading_library raise LabError("Script %s not in course library %s" % (name, course))
labs.laberrors. LabError: Script pods-container not in course library gl006
An error has ocurred. Check the logs for more details
[student@workstation ~]$

 

After requesting support from the Red Hat team, they helped me resolve it.

Eduardo6_1-1718986722269.png

 

 

rmokkink
Flight Engineer
Flight Engineer
  • 414 Views

Having the same issues. Nothing works

Chetan_Tiwary_
Moderator
Moderator
  • 412 Views

@rmokkink Please rebuild your lab and it will work. 

0 Kudos
rmokkink
Flight Engineer
Flight Engineer
  • 408 Views

no it does not, i deleted it and created the lab again twice today

0 Kudos
Join the discussion
You must log in to join this conversation.