riemann
Flight Engineer
Flight Engineer
  • 627 Views

DO188 CH08S02 hello-server pod gives error in logs or is not there

Jump to solution

When I start the openshift-applications lab I miss the line

SUCCESS checking pods are ready

Also sometimes I see

[student@workstation ~] $ oc get pods
name ready status restarts age
hello-client 1/1 Running 0 7m39s
hello-server 0/1 CrashLoopBackOff 6 (114s ago) 7m37s

or 

[student@workstation ~] $ oc get pods
name ready status restarts age
hello-client 1/1 Running 0 7m39s

In the latest case I tried:

$ oc run hello-server --image registry.ocp4.example.com:8443/redhattraining/podman-hello-server:latest

But then I get the same error as in the first case. In the GUI on the hello-server pod, under the logs tab I see that I should run

sudo chown -R "1000740000:0 /opt/app-root/src/.npm"

When I click the "debug container" link I get a terminal in /opt/app-root/src and I see that .npm/ is of default:root, so the chown is not permitted.

 

Also sometimes when I finished the lab, and start it again, it says that the project ocp-application is already there. Then I finish it again; then it is OK, but otherwise I have to do the same again.

 

 

 

Labels (1)
1 Solution

Accepted Solutions
Chetan_Tiwary_
Moderator
Moderator
  • 581 Views

Hello @riemann !

Please delete the existing lab entirely and create a new fresh lab environment - wait for 15-20 mins till the cluster is ready to accept the requests and then retry the lab :

Chetan_Tiwary__0-1704189087230.png

Regarding the project deletion, I am unable to see the same ( though I agree it might happen sometime - please report the same using the feedback button or via support case when you face it again - we will check it ) : 

Chetan_Tiwary__1-1704189559157.png

 

View solution in original post

2 Replies
Chetan_Tiwary_
Moderator
Moderator
  • 582 Views

Hello @riemann !

Please delete the existing lab entirely and create a new fresh lab environment - wait for 15-20 mins till the cluster is ready to accept the requests and then retry the lab :

Chetan_Tiwary__0-1704189087230.png

Regarding the project deletion, I am unable to see the same ( though I agree it might happen sometime - please report the same using the feedback button or via support case when you face it again - we will check it ) : 

Chetan_Tiwary__1-1704189559157.png

 

riemann
Flight Engineer
Flight Engineer
  • 576 Views

Hi Chitan_Tiwary,

Thanks, restarting the lab helped.

Greetings,

Eric Van der Velden

0 Kudos
Join the discussion
You must log in to join this conversation.