cancel
Showing results for 
Search instead for 
Did you mean: 
Meissa
Flight Engineer
Flight Engineer
  • 756 Views

DO280 4.5 lab errors

Hello everyone,

I'm facing issues with the Comprehensive review Lab from the DO280 training.

The errors are on the exercice number 6 and the exercice number 7.

There is a msql database connection issue in both of these labs. Even if I execute the command from the solution, I'm having the issues.

Can someone help me on that?

Regards

Labels (1)
0 Kudos
4 Replies
Anirudh
Mission Specialist
Mission Specialist
  • 732 Views

Re: DO280 4.5 lab errors

Hi,

Can you share the error you got for the mysql. If the issue is not solved still here are few troubleshooting steps:

1. Try reseting the lab and before starting a particular lab exercise use lab configuration command (specified at the start of each exercise)

 

2. Run  oc status and oc get pods to check the status of the Mysql database server.

 

If you still get the same error. Please do try after sometime (Make sure you start a new lab ) .

 

0 Kudos
Reply
Loading...
  • 661 Views

Re: DO280 4.5 lab errors

Hi, Meissa.

I'm facing the same problem. Wordpress pod logs says:

The server requested authentication method unknown to the client in Standart input code in line 22.

I was troubleshooting my deployments and secrets with the MYSQL_DB_PASSWORD, but found nothing... finally, I decided to google the error and it seems that mysql starting on version 8 is using a different authentication method.

I checked directly the mysql version on the mysql pod and found that it is using a v8.0.17. (even when the image tag is 5.7). That makes sense to me.

It's a bit frustraiting because mysql deployment is not working, they should fix the mysql image.

Check this about the error: https://github.com/docker-library/wordpress/issues/313

I'll keep testing a bit Smiley Happy let you know if I find something useful.

0 Kudos
Reply
Loading...
  • 658 Views

Re: DO280 4.5 lab errors

Hi, Meissa.

I made it work Smiley Very Happy The problem indeed is the mysql version. I removed mysql deployment and resources, and proceed deploying it with this image to test: 
docker.io/library/mysql:5.7 

Then I set the env of the mysql deployment with the secret and mysql pods were OK. I deleted wordpress pod to have a fresh one and it connected OK with mysql.
Now wordpress is working as expected, however since I used the docker hub image, maybe I will fail it, but I made it work and that's the important part.

For famous-quotes script, you would need to change mysql path to /usr/bin/mysql and add the password so mysql allows access to create the DB. (Otherwise you would need to rsh mysql pod and create "defaultdb" DB manually).

This will give you the opportunity to verify that your Openshift commands are OK. However the evaluation will fail since there's a task where it deletes "defaultdb" and tries to recreate it, but since the authentication requires root password, that task will be on "FAIL" status. 

Please let me know if that works for you!

0 Kudos
Reply
Loading...
msakho
Cadet
Cadet
  • 637 Views

Re: DO280 4.5 lab errors

I confirm that the issue comes from the image.

I have used the docker.io/library/mysql:5.7  and the registry.access.redhat.com/rhscl/mysql-57-rhel7:5.7-47 images.

Both are working for the wordpress. I think that the lab instructions should be changed to use the registry.access.redhat.com/rhscl/mysql-57-rhel7:5.7-47 instead.

So we can definetely say that our Openshift instruction are not OK.

What can we do to have those chnages corrected in the training labs?

Thanks

0 Kudos
Reply
Loading...
Join the discussion
You must log in to join this conversation.