Alec1
Cadet
Cadet
  • 1,495 Views

Chapter 8 Section 2 Guided Exercise Issue

Jump to solution

The execise start script creates and tries to start 2 pods, but the hello-server one does not start.  It gets an error.  Looking at the pod logs, I see the below error.

Alec1_0-1702413555210.png

 

 

1 Solution

Accepted Solutions
mecrobio
Flight Engineer
Flight Engineer
  • 1,094 Views

Hi @Alec1 

We just pushed a new classroom for this course.
The root cause of the problem was NPM not being able to write in the cache folder.
So we did a workaround in the Container files we use for the exercise apps

We tested the new classroom in production and everything is working as expected.

Thank you very much for your feedback, and sorry for any inconvenience!

 

View solution in original post

11 Replies
Wasim_Raja
Moderator
Moderator
  • 1,200 Views

@Alec1 Thanks for reaching out, this is a known issue and bug for this has already been logged.

@mecrobio Can you please help us here.

mecrobio
Flight Engineer
Flight Engineer
  • 1,187 Views

Hi,

The problem is a bug in NPM & the cache folder.
The same problem appeared in DO288. We found a solution for DO288, and we are trying to apply a similar fix for this app of DO188.

We will keep you posted.

 

Thank you!

Wasim_Raja
Moderator
Moderator
  • 1,182 Views

Thank you @mecrobio do let us know.

0 Kudos
Chetan_Tiwary_
Moderator
Moderator
  • 1,121 Views

Thanks for letting us know @mecrobio !

mecrobio
Flight Engineer
Flight Engineer
  • 1,095 Views

Hi @Alec1 

We just pushed a new classroom for this course.
The root cause of the problem was NPM not being able to write in the cache folder.
So we did a workaround in the Container files we use for the exercise apps

We tested the new classroom in production and everything is working as expected.

Thank you very much for your feedback, and sorry for any inconvenience!

 

Chetan_Tiwary_
Moderator
Moderator
  • 1,092 Views

@mecrobio Thank you so much for the swift reponse. 

0 Kudos
Wasim_Raja
Moderator
Moderator
  • 1,081 Views

Thank you @mecrobio for the quick resolution. Have a good day!!

0 Kudos
Adolph
Cadet
Cadet
  • 915 Views

Hi, it looks like I am still having this error:

I get "Your cache folder contains root-owned files, due to a bug in  previous versions of npm"

Hello-server will not start

mecrobio
Flight Engineer
Flight Engineer
  • 897 Views

Hi @Adolph,

Have you tried in a fresh classroom by recreating the whole lab environment? We just tested again the exercise in a new lab environment, and it works as expected.

 

Join the discussion
You must log in to join this conversation.