Trevor
Starfighter Starfighter
Starfighter
  • 421 Views

ansible-core & Ansible Automation Platform

"Ansible Automation Platform
ships with execution
environments that contain
ansible-core 2.15"

Does that statement mean that each execution environment 
has a separate installation of ansible-core?   If yes, does 
Ansible Automation Platform also consist of an installation 
of ansible-core - separate from the ansible-core in each
execution environment?

 

Trevor "Red Hat Evangelist" Chandler
Labels (1)
3 Replies
Chetan_Tiwary_
Moderator
Moderator
  • 406 Views

++ @Travis  

0 Kudos
Travis
Moderator
Moderator
  • 400 Views

@Trevor -

Everything here is slightly out of context. So it is very difficult to answer. The current version of AAP today for controller and private automation platform may very likely include and ship execution environments with ansible-core version 2.15. However, there are many versions of AAP and Automation Controller out there and it would be the execution environment that has ansible-core.

For example ... in RH294, it has AAP 2.2 and it had the ee-supported-rhel8 container image.

17│    name: Red Hat Enterprise Linux                                          ▒
18│    platform-id: platform:el8                                               ▒
19│    pretty-name: Red Hat Enterprise Linux 8.6 (Ootpa)                       ▒
20│    version: 8.6 (Ootpa)                                                    ▒
21│    version-id: '8.6'                                                       ▒
22│python:                                                                     ▒
23│  details:                                                                  ▒
24│    version: 3.9.7 (default, Sep 13 2021, 08:18:39)  [GCC 8.5.0 20210514 (Re▒
25│	 8.5.0-3)]
33│  version:                                                                  ▒
34│    details: ansible [core 2.13.3]

It has version 2.13.3.

So yes, AAP with the offline (bundled) installer for (Controller/Hub) does ship with default execution environments, but the version of ansible-core will change based on the AAP version bundle you have and the EEs are updated continually.

Ansible Automation Controller supports multiple EE images. I would suggest looking more and playing with the DO374 and DO467 courses as those shoudl give a good base on understanding.

Travis Michette, RHCA XIII
https://rhtapps.redhat.com/verify?certId=111-134-086
SENIOR TECHNICAL INSTRUCTOR / CERTIFIED INSTRUCTOR AND EXAMINER
Red Hat Certification + Training
Trevor
Starfighter Starfighter
Starfighter
  • 392 Views

Travis -

Shame on me for not being more specific with referecing
a specific version.  I know better, so I should, and will do
better!!!  It makes for unecessary heavy lifting in responding
when there is this type of vagueness in a query.  

Thank you for the response in spite of me!!!

 

Trevor "Red Hat Evangelist" Chandler
0 Kudos
Join the discussion
You must log in to join this conversation.