Highlighted
  • 1,380 Views

need license for bind?

hello all:

i have a redhat VM and it is licensed. i am trying to install bind-utils and keep getting this errors:

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

[root@localhost ~]# yum install bind-utils

Loaded plugins: product-id, search-disabled-repos, subscription-manager

rhel-7-server-eus-rpms                                                                                                                                                        | 2.0 kB  00:00:00     

rhel-7-server-extras-rpms

<snip>

--> Finished Dependency Resolution

Error: Package: 32:bind-libs-9.9.4-51.el7.x86_64 (rhel-7-server-eus-rpms)

           Requires: bind-license = 32:9.9.4-51.el7

           Installed: 32:bind-license-9.9.4-72.el7.noarch (@anaconda/7.6)

               bind-license = 32:9.9.4-72.el7

           Available: 32:bind-license-9.9.4-14.el7.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-14.el7

           Available: 32:bind-license-9.9.4-29.el7_2.4.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-29.el7_2.4

           Available: 32:bind-license-9.9.4-37.el7.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-37.el7

           Available: 32:bind-license-9.9.4-38.el7_3.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-38.el7_3

           Available: 32:bind-license-9.9.4-38.el7_3.1.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-38.el7_3.1

           Available: 32:bind-license-9.9.4-38.el7_3.2.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-38.el7_3.2

           Available: 32:bind-license-9.9.4-38.el7_3.3.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-38.el7_3.3

           Available: 32:bind-license-9.9.4-50.el7.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-50.el7

           Available: 32:bind-license-9.9.4-50.el7_3.1.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-50.el7_3.1

           Available: 32:bind-license-9.9.4-51.el7.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-51.el7

**********************************************************************

yum can be configured to try to resolve such errors by temporarily enabling

disabled repos and searching for missing dependencies.

To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf

**********************************************************************

 

Error: Package: 32:bind-libs-9.9.4-51.el7.x86_64 (rhel-7-server-eus-rpms)

           Requires: bind-license = 32:9.9.4-51.el7

           Installed: 32:bind-license-9.9.4-72.el7.noarch (@anaconda/7.6)

               bind-license = 32:9.9.4-72.el7

           Available: 32:bind-license-9.9.4-14.el7.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-14.el7

           Available: 32:bind-license-9.9.4-29.el7_2.4.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-29.el7_2.4

           Available: 32:bind-license-9.9.4-37.el7.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-37.el7

           Available: 32:bind-license-9.9.4-38.el7_3.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-38.el7_3

           Available: 32:bind-license-9.9.4-38.el7_3.1.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-38.el7_3.1

           Available: 32:bind-license-9.9.4-38.el7_3.2.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-38.el7_3.2

           Available: 32:bind-license-9.9.4-38.el7_3.3.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-38.el7_3.3

           Available: 32:bind-license-9.9.4-50.el7.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-50.el7

           Available: 32:bind-license-9.9.4-50.el7_3.1.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-50.el7_3.1

           Available: 32:bind-license-9.9.4-51.el7.noarch (rhel-7-server-eus-rpms)

               bind-license = 32:9.9.4-51.el7

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

>>>>>>>>>>>>>>>>>>>>>>>>>

do i need specifal lincense for bind? i merely want some bind utility tools installed.

 

Labels (1)
0 Kudos
5 Replies
Highlighted
Starfighter Starfighter
Starfighter
  • 1,377 Views

Re: need license for bind?

No, you don't need a special license for bind.  From my own system, these are the files included in this package:

[root@mcbutterpants ~]# rpm -ql bind-license
/usr/share/doc/bind-license-9.9.4
/usr/share/doc/bind-license-9.9.4/COPYRIGHT

Reading through the error messages you included above (thanks for that), it looks like you already have bind-license installed, but is a *NEWER* version than what is trying to be installed by the version of bind you're attempting to install.  Specifically:

You have bind-license-9.9.4-72.el7.noarch already installed on the system

You're trying to install bind-libs-9.9.4-51.el7.x86_64, which is trying to pull in the older bind-license-9.9.4-51.el7 as a dependency.

More than likely, this is being caused by your use of an eus yum repository.  Your existing bind-license is reported as being installed by anaconda (the system installer), so you may be on a later dot release than what the eus repo you've subscribed the system to provides.  That's my initial thoughts on the cause of the problem anyway...

-STM

 

--
Principle Technical Marketing Manager, Red Hat Enterprise Linux
Red Hat Certified Engineer (100-000-264)
0 Kudos
Reply
Loading...
Highlighted
  • 1,375 Views

Re: need license for bind?

thanks STM:

how could i fix this? i just want to install bind-utils

here is what i have:

[root@localhost ~]# rpm -ql bind-license

/usr/share/doc/bind-license-9.9.4

/usr/share/doc/bind-license-9.9.4/COPYRIGHT

here is my system:

Name : redhat-release-server 
Version : 7.6 
Release : 4.el7 
Architecture: x86_64 
Install Date: Mon 01 Apr 2019 02:35:50 PM PDT 
Group : System Environment/Base 
Size : 43632 
License : GPLv2 
Signature : RSA/SHA256, Wed 26 Sep 2018 04:25:27 AM PDT, Key ID 199e2f91fd431d51 
Source RPM : redhat-release-server-7.6-4.el7.src.rpm 
Build Date : Fri 21 Sep 2018 07:58:31 AM PDT 
Build Host : x86-040.build.eng.bos.redhat.com 
Relocations : (not relocatable) 
Packager : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla
Vendor : Red Hat, Inc. 
Summary : Red Hat Enterprise Linux Server release file 
Description : 
Red Hat Enterprise Linux Server release files 

_dave

0 Kudos
Reply
Loading...
Highlighted
Starfighter Starfighter
Starfighter
  • 1,366 Views

Re: need license for bind?

@linux_newbie

I'd suggest removing your system from the eus yum repo that you have it configured to use.  That is likely an eus for an earlier dot release (like 7.4 or 7.5), but you're using 7.6, which is the most current.

If that's not possible, you should downgrade the bind packages to match what's available in your eus repository.  More than likely, you have more than just a bind-license that's newer.  On my machine I also have bind-libs and bind-libs-lite, so you'd need to downgrade those as well so that they would match the older version of bind-utils you're attempting to install.

-STM

--
Principle Technical Marketing Manager, Red Hat Enterprise Linux
Red Hat Certified Engineer (100-000-264)
Reply
Loading...
Highlighted
  • 1,352 Views

Re: need license for bind?

hi scoot:

how could i update the eus yum repo to current system repo? could you provide the deatils of procedure?

 

_dave

0 Kudos
Reply
Loading...
Highlighted
Flight Engineer Flight Engineer
Flight Engineer
  • 1,347 Views

Re: need license for bind?

Hi Dave,

When you subscribe RHEL it enables repos of all the associated products.I sugggest you enable the repos you need, you may need to investigate the role of your system, what services you wish to run etc.
Cheers !!
Vijay
0 Kudos
Reply
Loading...
Join the discussion
You must log in to join this conversation.