sidd123
Cadet
Cadet
  • 2,088 Views

Authconfig-gtk Does Not Launch

Unable to initialize graphical environment. Most likely cause of failure, is that the tool was not run using a graphical environment? Please either start your graphical user interface or set your DISPLAY variable.

I can not get authconfig-gtk to launch, my system is set to graphical and yet it does not work, how do I get it to work to configure ldap via gui?

Tags (3)
1 Reply
upsetwithrh
Mission Specialist
Mission Specialist
  • 1,064 Views

you don't -  at least not in rhel 8. it is deprecated and replaced by authselect.  The easiest way I've found is to install nslcd and nss-pam-ldapd (also deprecated), copy/edit the sssd configuration replacing sss with ldap.  The ver 8 release notes talk about moving away from OpenLDAP towards 389 DS as "justification" (YMMV) but that's the thinking. 

Join the discussion
You must log in to join this conversation.