fmarchioni
Mission Specialist
Mission Specialist
  • 434 Views

[DO288] Cannot connect to an OCP 4.5 API using the cluster URL

Hi,

I'm just trying to run the lab-configure to set up the D0288 environment.

I've tried a couple of times to create the VM, but the result is still the same:

"Cannot connect to an OCP 4.5 API using your URL. Please verify your network Connectivity and that the URL does not point to an OCP 3 cluster...."

I've tried opening the OCP Console URL from the browser:

https://api.cluster.domain.example.com:6443

However the host simply cannot be found.

Do I miss any network settings before the lab-configure action?

Thanks

Francesco

fmarchio@redhat.com

0 Kudos
5 Replies
flozano
Moderator
Moderator
  • 402 Views

Re: [DO288] Cannot connect to an OCP 4.5 API using the cluster URL

You are expected to replace the "https://api.cluster.domain.example.com:6443" place holder URL with the real URL of your cluster, as provided by ROLE.

This is an example of how it should look, it is a screen shot from an actual student. See the value of "API Endpoint"

Untitled.png

0 Kudos
Reply
Loading...
flozano
Moderator
Moderator
  • 399 Views

Re: [DO288] Cannot connect to an OCP 4.5 API using the cluster URL

The following thread shows where to get the URL you need. It is from DO180 but should be the same for DO288

https://learn.redhat.com/t5/Containers-DevOps-OpenShift/DO180-issue-connecting-to-API-endpoint-not-f...

Reply
Loading...
fmarchioni
Mission Specialist
Mission Specialist
  • 390 Views

Re: [DO288] Cannot connect to an OCP 4.5 API using the cluster URL

Thanks for your reply. I have checked the "Lab Environment Tab" but it does not show the OCP cluster address. I've tried with firefox 70.0 and the latest Chrome.

In the linked thread, it was mentioned that the cluster lab had some issues in the past. Can this be the reason?

My browser snapshot:

snapshot.png

0 Kudos
Reply
Loading...
fmarchioni
Mission Specialist
Mission Specialist
  • 389 Views

Re: [DO288] Cannot connect to an OCP 4.5 API using the cluster URL

Oh wait, I did just one more (desperate) try with Chrome, deleting the cluster and re-creating it. Now it shows the info.

So this info shows only when you create the cluster and not when you start a stopped cluster.

So the issue is solved. Thanks

0 Kudos
Reply
Loading...
flozano
Moderator
Moderator
  • 380 Views

Re: [DO288] Cannot connect to an OCP 4.5 API using the cluster URL

Oh yes, you need a running classroom to get the connection info.

0 Kudos
Reply
Loading...
Join the discussion
You must log in to join this conversation.