Highlighted
  • 366 Views

DO405 Outdated, PuppetForge not working anymore

Jump to solution

Hi all,

Today I was working on DO405, chapter 12: Implementing External Puppet Modules

In both Guided Exercise and LAB I was asked to install modules from Puppet Forge. However, the current versions of those modules (puppetlabs-motd and puppetlabs-apache) are built for Puppet 5.5.10>, and DO405 is still based on Puppet 3.6.

In order to pass the lab, I had to manually download older versions with its dependencies. For Apache, this was:

 

wget https://forge.puppet.com/v3/files/puppetlabs-apache-1.8.0.tar.gz
wget https://forge.puppet.com/v3/files/puppetlabs-stdlib-4.12.0.tar.gz
wget https://forge.puppet.com/v3/files/puppetlabs-concat-1.2.5.tar.gz

 

And I installed them with

puppet module install --modulepath=. puppetlabs-stdlib-4.12.0.tar.gz
puppet module install --modulepath=. puppetlabs-concat-1.2.5.tar.gz
puppet module install --modulepath=. puppetlabs-apache-1.8.0.tar.gz

This way I was successfully able to finish the LAB.

Is there any official way to do this? Can puppet automatically download a version of the module that is compabible with the Puppet version in use? I found that it also installed too new versions of the dependencies, so that also didn't work as I expected.

--

EDIT: Today I learned from another practice in Chapter 14 that working versions of the modules are already present inside the classroom-environment at http://materials.example.com/

Nevertheless, the excersises are still broken in their current form.

1 Solution

Accepted Solutions
Highlighted
Flight Engineer Flight Engineer
Flight Engineer
  • 335 Views

Re: DO405 Outdated, PuppetForge not working anymore

Jump to solution

Thanks for reporting this @GertjanBijl. I'm sorry to hear that you are experiencing issues accessing PuppetForge. I will get in touch with the developers who will determine the best course of action.

View solution in original post

Reply
Loading...
1 Reply
Highlighted
Flight Engineer Flight Engineer
Flight Engineer
  • 336 Views

Re: DO405 Outdated, PuppetForge not working anymore

Jump to solution

Thanks for reporting this @GertjanBijl. I'm sorry to hear that you are experiencing issues accessing PuppetForge. I will get in touch with the developers who will determine the best course of action.

View solution in original post

Reply
Loading...
Join the discussion
You must log in to join this conversation.