cancel
Showing results for 
Search instead for 
Did you mean: 
Rajbatra
Mission Specialist
Mission Specialist
  • 2,167 Views

Lab DO280 - unable to start openshift 4.2 lab

Hi,

I am trying to build Openshift4.2 lab, when i am running lab-configure command, it is coming the below error.

[student@workstation ~]$ lab-configure

This script configures the connection parameters to access the OpenShift cluster for your lab scripts

· Enter the Cluster API URL: https://api.cluster.domain.example.com:6443
· Enter the Cluster ID: long-and-random-hexadecimal-string
· Enter the Wildcard Domain: apps.cluster.domain.example.com
· Enter the Cluster Password: long-and-random-password

You entered:
· Cluster API URL: https://api.cluster.domain.example.com:6443
· Cluster ID: long-and-random-hexadecimal-string
· Wildcard Domain: apps.cluster.domain.example.com
· Cluster Password: long-and-random-password

Verifying your Cluster API URL...

ERROR:
Cannot connect to an OpenShift 4 API using your URL.
Please verify you network connectivity and that the URL does not point to an OpenShift 3.x nor to a non-OpenShift Kubernetes API.
No changes made to your lab configuration.
Entered information saved to: /usr/local/etc/do280.ocp4.config-failure

Kindly help me to build the lab.

Thanks & Regards

Raj Kumar Batra

 

0 Kudos
9 Replies
Walid
Flight Engineer Flight Engineer
Flight Engineer
  • 2,154 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

the cluster API URL you shared above looks wrong, you should open ROL url from inside your lab and copy these details from the lab page into the script. most of the values are copy and paste except the URL, you need to prefix it with "https://".

~ Walid - the DevOps Janitor
0 Kudos
Reply
Loading...
Rajbatra
Mission Specialist
Mission Specialist
  • 2,148 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

I had followed the same steps which are mentioned in Guided Exercise : Configuration a Lab Environment and given the Note under the lab Exercise 

To avoid problems pasting text into the workstation machine, open the Firefox browser on workstation and navigate to https://rol.redhat.com. Copy the necessary values from Firefox and paste them into the GNOME Terminal window.

I opend the ROL page from my workstation and paste url from inside my Lab.

Verify that you provided the correct values for your OpenShift cluster to the lab-configure command. You entered:
· Master API URL:            https://api.cluster.domain.example.com:6443
· Cluster ID:                long-and-random-hexadecimal-string
· Wildcard Domain:           apps.cluster.domain.example.com
· Kubeadmin User Password:   long-and-random-password

After done that , Still showing error.

Rajkumar Batra

 

 

 

 

 

 

 

0 Kudos
Reply
Loading...
Walid
Flight Engineer Flight Engineer
Flight Engineer
  • 2,145 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

 

if you open the lab tab and start your lab, you should see the configuration info, it looks something like the image below,  the ones you gave above does not show the same api, it is show the default generic API url which will not work, you need to copy from your own cluster/setup info from the lab tab. I hope it is clear, if you have standard subscription check with the online chat too.

do280.png

~ Walid - the DevOps Janitor
Reply
Loading...
Verwolff
Mission Specialist
Mission Specialist
  • 2,070 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

I am trying to access this DO280 lab too. In my case, I can't even start any command line to configure those values. Bastion and classroom are not accessible with the provided password and the workstation is booting to graphical interface with a single student account. When entered into Desktop mode (using password student) there is no command-line access OpenShift_lab.jpg

0 Kudos
Reply
Loading...
Walid
Flight Engineer Flight Engineer
Flight Engineer
  • 2,049 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

what happens if you click on the RedHat at the top left corrner? what do you see, can you start the workstation or reset it if you when you right click or click on the logo you still do not see apps espicially terminal 

~ Walid - the DevOps Janitor
0 Kudos
Reply
Loading...
Verwolff
Mission Specialist
Mission Specialist
  • 2,046 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

This time, after another lab rebuild, I can start labs. Thanks for your answer.

0 Kudos
Reply
Loading...
psrh08
Mission Specialist
Mission Specialist
  • 1,898 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

Getting login issue while configuring DO280 4.2 Lab using lab-configure, please help. Attached is the screenshot as well.Capture.PNG

0 Kudos
Reply
Loading...
Singh
Flight Engineer Flight Engineer
Flight Engineer
  • 1,892 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

@psrh08 Error is cannot log in to Openshift as kubeadmin, so re-check your password. Sometimes copy paste changes a few words from small to capital and vice versa.

Thanks

Singh

0 Kudos
Reply
Loading...
psrh08
Mission Specialist
Mission Specialist
  • 1,889 Views

Re: Lab DO280 - unable to start openshift 4.2 lab

Thanks, it worked Smiley Happy

0 Kudos
Reply
Loading...
Join the discussion
You must log in to join this conversation.