Highlighted
Mission Specialist
Mission Specialist
  • 730 Views

RH436 Lab Error

Hi,

I am having an issue in RH436 Lab. When I run the "lab hacluster setup", it show me that "Unable to download grading function, Contact lab instructor". 

Regard,

Yan 

0 Kudos
21 Replies
Highlighted
Moderator
Moderator
  • 712 Views

Re: RH436 Lab Error

Hi there,

Are all the machines of the lab up and ready?

In doubts you can always do a reset (knowing it will delete everything on these machines).

After that, if it still does not work, your best bet is you contact the support.

I did that course a few months ago, I did not encountered such issues.

Cheers,

Reply
Loading...
Highlighted
Mission Specialist
Mission Specialist
  • 320 Views

Re: RH436 Lab Error

gfs2-lvm-creation-again&again.PNG

Absar Ahammad Shaik
0 Kudos
Reply
Loading...
Highlighted
Mission Specialist
Mission Specialist
  • 319 Views

Re: RH436 Lab Error

Hi Moderator,

The LAB issue is not yet fixed and your support is failing to provide a solution rather they are providing a workaround but not the solution, so what is the use of study guide if it is not working as per LAB?

Please refer to Case Number : #02750581.

I have appeared EX436 exam two days back and even during the same issue, after configuring everything perfectly, multipath -ll is not showing anything? after executing lsblk, found that /dev/sda as common disk across all the nodes and / or /boot are having /dev/vda, so i added them to blacklist but still it was not showing anything. When i asked the proctor about this issue he asked me to check with support after exam and when i checked support after exam they are saying everything was alright and no issues?  this is 4 attempts i have wasted behind RH 436!!!! if this the way it continues what is the trust should i have on Red HAt and thier exams?  in the same exam i tried configuring gfs2 partition by using available common disk /dev/sda and when i did pvcreate,vgcreate and lvcreate it was throwing below error the same error which we are facing in Practice LAB in RHLS!!!!!! ofcourse i have enable lvmconf --enable-cluster and lvmetad stopped and locking_type to 3,

 

Who will take accountability and where is the transparency?

 

Error:

# pvcreate /dev/sda
connect() failed on local socket: No such file or directory
Internal cluster locking initialization failed
WARNING: Failing back to local file-based locking.
Volume Groups with the clustered attribute will be inaccessible.
Physical volume "/dev/sda" successfully created

# vgcreate -Ay -cy clustervg /dev/sda
connect() failed on local socket: No such file or directory
Internal cluster locking initialization failed
WARNING: Failing back to local file-based locking.
Volume Groups with the clustered attribute will be inaccessible.
Clustered volume group "clustervg" successfully created

# lvcreate -L 1G -n clusterlv clustervg
connect() failed on local socket: No such file or directory
Internal cluster locking initialization failed
WARNING: Failing back to local file-based locking.
Volume Groups with the clustered attribute will be inaccessible.
Skipping clustered volume group clustervg
 
 
Absar Ahammad Shaik
0 Kudos
Reply
Loading...
Highlighted
Moderator
Moderator
  • 310 Views

Re: RH436 Lab Error

Hi @AbsarShaik ,

Unfortunately I don't have much time to help you now. I just want to say that you are in the community forum for learners, any sort of official feedback should be going though the support or for post exams feedback, to the comments form:
https://rhtapps.redhat.com/comments/ .

I actually attended the RH436 course and the EX436 exam (failed twice, passed third attempt). I found some issues with the course and reported them internally, the one you are mentionning is not one of them.

I saw you copied some extracts, they are not very useful without knowing your setup and the context. I mean you can have a "lab1" with zero disk and it would be normal that some commands are failing if it is expecting to have some disks.

Therefore, if you want help from the community, like another learner who attended RH436, you will need to describe your issue with more details. For example, which page of the instructions you are in. That would also help if you copy the exact steps you took (such as resetting the lab and running the relevant lab setup command).

I'd be happy to try to start a lab and run the commands in parallel, I am flooded with other work and won't be able to help you shortly. Let's hope another learner can also help you in the meantime.

Cheers,

0 Kudos
Reply
Loading...
Highlighted
Mission Specialist
Mission Specialist
  • 303 Views

Re: RH436 Lab Error

Hi @JS_Learning ,

I have been facing issue with "Chapter - 13 - Comprehensive Review of Red Hat High-availability Clustering" LAB & after doing,

iscsi - successful

multipathing - successful

lvmconf --enable-cluster & locking_type = 3 & stop lvm2-lvmetad - successful

created resources ( dlm-clone, clvmd-clone and constraints are successful )

============================================================

Now issue starts:

# pvcreate /dev/mapper/mpatha
connect() failed on local socket: No such file or directory
Internal cluster locking initialization failed
WARNING: Failing back to local file-based locking.
Volume Groups with the clustered attribute will be inaccessible.
Physical volume "/dev/mapper/mpatha" successfully created

# vgcreate -Ay -cy clustervg /dev/mapper/mpatha
connect() failed on local socket: No such file or directory
Internal cluster locking initialization failed
WARNING: Failing back to local file-based locking.
Volume Groups with the clustered attribute will be inaccessible.
Clustered volume group "clustervg" successfully created

# lvcreate -L 1G -n clusterlv clustervg
connect() failed on local socket: No such file or directory
Internal cluster locking initialization failed
WARNING: Failing back to local file-based locking.
Volume Groups with the clustered attribute will be inaccessible.
Skipping clustered volume group clustervg

==========================================================

The same above issue I had faced in the exam as well, and the proctor simply said to open the case and I already opened a case with https://rhtapps.redhat.com/comments/   and they simply replied everything was fine during the exam without justification!!!! so if it goes this way then I will never pass the exam in my lifetime and by the way, this is my 4th attempt that I am failed the exam. 

 

Thanks

Absar Ahammad Shaik
0 Kudos
Reply
Loading...
Highlighted
Moderator
Moderator
  • 171 Views

Re: RH436 Lab Error

Hi @AbsarShaik 

For you, I tried reproducing the exercice.

I had almost forgotten everything, after 1.5 years (learning far too many topics at the moment). It was rather a pain to reach the steps 10.x and was rather long (I easily spent two hours, especially I was doing something dumb with scp, no comments Smiley Very Happy).

Bottom line is I don't have the same problem as you. I doubt it's a lab infra problem since we are using the same. I'm afraid that is probably indicating you are doing something wrong (several times). I think I remember I was doing the same a long time ago with RH436, making the same typo over and over again until I quadruple checked...and finally found.

I can just comment on how long the exercice is, how it's difficult to make a mistake (I made a few in my last attempt today). I don't know exactly how it went wrong but it's very easy to mix where to run the commands, sometimes it's on nodea only, sometimes on all nodes.

That exercice is a hard example and it's not easy to troubleshoot either.

I have managed:

Screenshot from 2020-09-28 17-22-12.png

 

To make things more complex, copying/pasting long instructions to the terminal in that old Ravelo interface was and is a pain. Luckily that has been slightly improved in newer courses using "Novello". I was missing the -l in the commands "iscsiadm -m node -T iqn.2015-06.com.example:cluster -p 192.168.2.9 -l" (that was truncated in the copy/paste garbage feature) and therefore it was not login properly.

See it's supposed to look like this when properly login:

Screenshot from 2020-09-28 17-27-20.png

And when I was using the truncated command (see the -l is missing):

Screenshot from 2020-09-28 17-31-15.png

I'm going to delete the lab and exercice now. I don't have the luxury to spend more time on that lab Smiley Wink

Triple check, redo, it's easy to make a mistake but it's supposed to work. That's an opportunity to learn each steps how to verify if something has been properly completed. It's something, that I find important to pass the exam.

Good luck for the exercice and exam!

 

0 Kudos
Reply
Loading...
Highlighted
Moderator
Moderator
  • 305 Views

Re: RH436 Lab Error

@cschunke Hi, do you think you can find someone to help @AbsarShaik with those issues?

Thanks in advance,

 

0 Kudos
Reply
Loading...
Highlighted
Mission Specialist
Mission Specialist
  • 318 Views

Re: RH436 Lab Error

The Interesting part, before 5 minutes of  leaving the examination, i tried the same commands,

 

lvcreate -L 1G -n lvname clustername

 

mkfs.gfs2 -j3 -p lock_dlm -t clusterX:servicename /dev/clustername/lvname 

 

Worked perfectly!!!!!! and when i asked the proctor about the same then he said he cannot help as exam time is finish and asked me to open the case and support people simply saying that everything is alright, if Red Hat is blocking all the ways without transparency then how to get the justice? 

Absar Ahammad Shaik
0 Kudos
Reply
Loading...
Highlighted
Mission Specialist
Mission Specialist
  • 705 Views

Re: RH436 Lab Error

Hi There,

I too have the same issue here with RH436 LAB, I've travelled hundreds of kilometres to a different where RedHat exam station is available and I wanted to practice before appearing exam but LAB issue is not fixed from more than 5 days and Red Hat Support is not even responding for support case though I have opened it with Severity # 1.

Because of this, I had to cancel all my prescheduled tasks, which cost me too much.

I am totally upset and feeling like not to buy RHLS ever again. 

Thanks,

Absar Ahammad Shaik
Reply
Loading...
Join the discussion
You must log in to join this conversation.