cancel
Showing results for 
Search instead for 
Did you mean: 
jacuzi
Mission Specialist
Mission Specialist
  • 787 Views

Ansible Automation Platform - Playbook Inventory Python dependencies

If an inventory.py is complaining about missing Python dependencies (python36 and python3-ldap) in the command line Playbook run what would be the location one would need to install them?

1. In the server from where the Playbook is run?

2. Localhost (Container)?

- If this option what would be the method to install those if you are not creating a new Execution        Environment?

3. The Managed nodes?

 

Confused...

Labels (2)
0 Kudos
2 Replies
bonnevil
Starfighter Starfighter
Starfighter
  • 778 Views

@jacuzi  We'd need more information to help you.  In particular, what version of AAP are you running, and what version of RHEL are you running?  Is this in a lab environment for one of Red Hat's courses, or is this something on one of your own systems?  Are you using ansible-navigator, and if you are, what execution environment (container) are you using?  Or are you using ansible-playbook (and therefore the host's own environment)?

0 Kudos
jacuzi
Mission Specialist
Mission Specialist
  • 754 Views

@bonnevil 

- AAP 2.2

- RHEL 8.6

- Using ansible-navigator with ee-supported-rhel8:latest

seems like the playbook and the image.py works fine with ee-minimal-rhel8:latest but I might have to make it run with the ee-supported-rhel8:latest image

 

 

0 Kudos
Join the discussion
You must log in to join this conversation.