cancel
Showing results for 
Search instead for 
Did you mean: 
fravis
Cadet
Cadet
  • 1,085 Views

Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI exerc

During my Guided Exercise: Managing an Application with the CLI the oc logs -f bc/quotesapi command suddenly didn't work anymore (timeout).
So, in order to try to solve my self the problem, I tried again the DO288/4.5 lab-configure operation, using 

API Endpoint RHT_OCP4_MASTER_API https://api.eu45.prod.nextcle.com:6443


Anyway, the following strange red blocking error appears:
Cannot connect to an OpenShift 4.5 API using your URL.
Please verify .... 

Can anyone suggest me a solution to go on witOpenShift 4_5 API connection error during lab-configure.jpg

0 Kudos
9 Replies
jordisola
Flight Engineer
Flight Engineer
  • 1,068 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

Hi

I just tried the same lab-configure with the same cluster and it worked fine.

Maybe the cluster had some hiccup? Can you please give it another try?

Untitled.png

Kind regards

Jordi Sola

Reply
Loading...
ronyhaddad
Mission Specialist
Mission Specialist
  • 874 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

I am having a similar issue in the DO180 course but will post separately about it. Sorry I could not delete my reply.

0 Kudos
Reply
Loading...
naser
Cadet
Cadet
  • 565 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

Cannot connect to an openShift 4,5 API using your URL duting my DO180.DO180.PNG

I really need some help if theres any one can explen to me how to fix this issue .

Reply
Loading...
jordisola
Flight Engineer
Flight Engineer
  • 551 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

Hi @naser 

The user you are typing (naser.shiqwara@...) seems a private username.

As per https://rol.redhat.com/rol/app/courses/do288-4.6/pages/ch01s03, you must use the credentials provided in your lab environment: 
Hope that helps.

Kind regards

Jordi Sola

Reply
Loading...
Jwhite518
Mission Specialist
Mission Specialist
  • 446 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

Having this issue setting up my lab environment. Have used all the credentials provided during my lab creation. I have tried two different names for github - my login username, and my profile username, which do not match. How do I get help on this?

2021-08-23 15_56_11-Window.png

Reply
Loading...
jordisola
Flight Engineer
Flight Engineer
  • 426 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

Hi JWhite

The credentials are ok (despite I can't find any `jwhite0` user in Quay.io).

I know we had an outage a few days ago with NA OCP clusters. Maybe you were just unlucky.

Would you please try again?

Nevertheless, be aware that DO288/4.5 is about to be retired next November, so I would encourage you to move to 4.6. This version includes OCP updates and some content updates and bug fixes you might find interesting.

 

I hope that helps! Kind regards

 

Jordi Sola 

Reply
Loading...
Jwhite518
Mission Specialist
Mission Specialist
  • 416 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

Jordi,

I piggybacked on an existing thread regarding the lab setup for DO288. Checking  my course, I am definitely using OCP 4.6. Thanks for the heads up.

Regarding quay.io, when I go onto the quay website it appears that my account name is jbwhite0. Though I realize quay uses SSO with redhat.com. So in the setup script for the DO288 lab, do I use the quay account name or my RH account name? See quay screenshot. 2021-08-24 08_10_23-Window.png

0 Kudos
Reply
Loading...
Jwhite518
Mission Specialist
Mission Specialist
  • 415 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

And now you can disregard my question because it's all working today. It must have been an outage yesterday. jbwhite0 did work during the setup. Thank you.

2021-08-24 08_14_49-Window.png

0 Kudos
Reply
Loading...
jordisola
Flight Engineer
Flight Engineer
  • 400 Views

Re: Connection error to Openshift 4.5 API during my DO288/4.5 Managing an Application with the CLI e

Glad it worked fine!

Enjoy the course!

 

Jordi Sola

Reply
Loading...
Join the discussion
You must log in to join this conversation.