ViniBaimas
Mission Specialist
Mission Specialist
  • 252 Views

DO280 - Lab chapter 4 - Guided Exercise: Protect External Traffic with TLS

Hi, 

I have a problem with my lab in the second step. When I exposed a service, my browser don't show me the application works.

I use the version 4.14.0


Follow the prints.

We can help me ?

Captura de Tela 2024-06-10 às 19.03.49.pngApplication is not availableApplication is not available

Labels (1)
0 Kudos
4 Replies
Artemis-NASA
Mission Specialist
Mission Specialist
  • 238 Views

Dear ViniBaimas

you need to check inside svc yaml might be there is wrong Lable or wrong port

oc get logs pod/container

oc get logs deplyoment/app

0 Kudos
ViniBaimas
Mission Specialist
Mission Specialist
  • 235 Views

Dear @Artemis-NASA !

 

Great for your answer, but the Labels is correct... I don't found the error... see my prints.

The svc called the pod across of the label name: todo-http

Captura de Tela 2024-06-10 às 19.52.33.pngCaptura de Tela 2024-06-10 às 19.55.42.png

0 Kudos
ViniBaimas
Mission Specialist
Mission Specialist
  • 218 Views

Dear colleagues,

I did can to solve the problem !

I discovery that existed a project with a route of the same name. I deleted the project and the route is worked

Thanks to everyone

Captura de Tela 2024-06-10 às 20.53.35.pngCaptura de Tela 2024-06-10 às 20.58.24.png

0 Kudos
Artemis-NASA
Mission Specialist
Mission Specialist
  • 211 Views

Great to hear that  ViniBaimas , best thing learn by mistake , mistake not a failure it is just a part of success 

0 Kudos
Join the discussion
You must log in to join this conversation.