adge
Cadet
Cadet
  • 274 Views

DO380 v4.14 oadp 1.2 not available

Jump to solution

I've just gone through the DO380 v4.14 backup-review section and I'm a bit confused about the versions of oadp. The lab start backup-review scripts deploys v1.3 where as the solution and course materials talk about v1.2 and the config differs between them. Is that on purpose?

When I did practice it earlier today (10:30 UTC) it all worked fine and v1.2 was available.

Thanks,

Labels (3)
1 Solution

Accepted Solutions
Natalie_Lind
Flight Engineer
Flight Engineer
  • 113 Views

Hi there! We just released an update to this course that was officially available as of Wednesday, June 19th, though our release process started on Monday, June 17th. In this release, we updated the OADP operator to 1.3, which required updating our lab scripts. I suspect you happened to get the updated lab scripts just before the updated text content and lab environment were available. If you recreate your lab, then you should have the latest version of everything. The HTML, ePub, and PDF of the course also show the latest changes now.

Natalie Watkins
Manager - Technical Training, OpenShift Platforms
Product & Technical Learning

View solution in original post

2 Replies
adge
Cadet
Cadet
  • 239 Views

Quick Update:

I've figured out how to make oadp work for this lab.

With version 1.3 the following attributes have to be set in the oadp config:

- spec.configuration.nodeAgent.enable

- spec.configuration.nodeAgent.uploaderType

- spec.configuration.velero.defaultSnapshotMoveData

- spec.configuration.velero.defaultPlugins

Specifying the 'vsm' plugin is deprecated in 1.3. 

Natalie_Lind
Flight Engineer
Flight Engineer
  • 114 Views

Hi there! We just released an update to this course that was officially available as of Wednesday, June 19th, though our release process started on Monday, June 17th. In this release, we updated the OADP operator to 1.3, which required updating our lab scripts. I suspect you happened to get the updated lab scripts just before the updated text content and lab environment were available. If you recreate your lab, then you should have the latest version of everything. The HTML, ePub, and PDF of the course also show the latest changes now.

Natalie Watkins
Manager - Technical Training, OpenShift Platforms
Product & Technical Learning
Join the discussion
You must log in to join this conversation.