e719
Mission Specialist
Mission Specialist
  • 5,075 Views

DO288 lab2 (ch2s07)

hi everybody. I have error when trying to run through lab ch2s07


oc new-app --name elvis \
> quay.io/e719/do288-hello-java
W0220 17:12:43.348779 7576 dockerimagelookup.go:237] container image registry lookup failed: quay.io/e719/do288-hello-java:latest: missing signature key
error: local file access failed with: stat quay.io/e719/do288-hello-java: no such file or directory
error: unable to locate any images in image streams, templates loaded in accessible projects, template files, local docker images with name "quay.io/e719/do288-hello-java"

I make it visible by settings-visibility-make public
A month ago I did other lab from ch2 with do288-apache image. It still there and works fine with oc new-app.

Any ideas?

P.S. Is it special Unix-style challenge to post here a message? While you type in message text, authentication expires, you press post and it shows you ERROR bla-bla-bla, and your message is lost. Now I'm trying to write it again - and it even shows me "autosaved at ... P.M." (not first time it happen)
Very funny

Labels (2)
22 Replies
danielenegroni
Mission Specialist
Mission Specialist
  • 1,524 Views

I used the --format v2s1 flag in my skopeo copy command, and it works!

For example labs ch03s06:

podman login -u ${RHT_OCP4_QUAY_USER} quay.io

skopeo copy \ oci:/home/student/DO288/labs/expose-image/php-info \ docker://quay.io/${RHT_OCP4_QUAY_USER}/php-info --format v2s1

oc login ...
oc new-project ..

oc create secret generic quayio \ --from-file .dockerconfigjson=${XDG_RUNTIME_DIR}/containers/auth.json \ --type kubernetes.io/dockerconfigjson

oc import-image php-info --confirm \ --reference-policy local \ --from quay.io/${RHT_OCP4_QUAY_USER}/php-info 

0 Kudos
Adam_Yates
Flight Engineer Flight Engineer
Flight Engineer
  • 2,154 Views

I can confirm as well that I'm having this issue when teaching DO288 in ch3 s02 - Guided Exercise:Allowing access to the OpenShift Registry

  • 1,319 Views

In addition to current problem, almost same thing happens at ch03s02 (Guided Exercise: Using an Enterprise Registry). Different thing from the current bug is, this time you copy your image with skopeo, not podman.

 

I solved  problem via same workaround  at this thread.

 

Just put a --format v2s1  line  to your skopeo copy command. For example  :

 

skopeo copy --format v2s1 oci:/home/student/DO288/labs/external-registry/ubi-sleep docker://quay.io/${RHT_OCP4_QUAY_USER}/ubi-sleep:1.0

 

after the copy you can create your pod with your quay.io repository image.

 

Hope this helps!

  • 907 Views

Thank you.

0 Kudos
Eash
Cadet
Cadet
  • 961 Views

Teaching this class DO288 on OCP 4.6, I came across this issue for the first time. what is the cause of this issue? Is it a OCP 4.6 issue? 

0 Kudos
ricardo_jun
Moderator
Moderator
  • 873 Views

Hi everyone,

This issue should be fixed when the course updates to OCP4.10 as this is a known bug (https://issues.redhat.com/browse/PROJQUAY-3285)
Hope that helps.

Thanks
Rob-L
Mission Specialist
Mission Specialist
  • 813 Views

This worked for me .. adding the '--format=docker' option to the podman build

podman build --format=docker --layers=false -t do288-apache ./container-build/

Rob-L
Mission Specialist
Mission Specialist
  • 795 Views

I also got the same problem with chapter 3 guided exercise using an enterprise repo@ricardo_jun it would be good to get these defects fixed as you do spend a fair bit of time debugging the problem, though debugging the problem could be thought of as good bonus  learning .

I used the --format option as suggested earlier in this thread to overcome the issue

skopeo copy --format v2s1 oci:/home/student/DO288/labs/external-registry/ubi-sleep docker://quay.io/${RHT_OCP4_QUAY_USER}/ubi-sleep:1.0

 

ricardo_jun
Moderator
Moderator
  • 756 Views

I'll raise the attention to @zachgutterman as he is the architect that would shed some light on when this issue will be fixed.

 

Thanks for debugging anyway @Rob-L 

ywlearner
Cadet
Cadet
  • 683 Views

For 3.2 adding --format v2s1 or oci to skopeo copy doesn't work. It persist and I don't know how to build from oci format unlike podman containerfile in ch2.

Join the discussion
You must log in to join this conversation.