cancel
Showing results for 
Search instead for 
Did you mean: 
  • 2,000 Views

Do280 chapter 5 Lab issue

Jump to solution

Hello all,
Hoping someone may have run into the same issue I am seeing and have a solution.

In the final lab for chapter 5 we are instructed to do the following:

Use a text editor to update the php-http.yaml file as follows:

  • Set the image to use the container image accessible at quay.io/redhattraining/php-ssl:v1.0.

  • Locate the containerPort entry and set the value to 8080, which corresponds to the insecure endpoint.

After completing the above change to the php-http.yaml file, we are then supposed to do a deploy using the yaml file.

oc create -f php-http.yaml


This however results in an error:
Error from server (BadRequest): error when creating "php-http.yaml": Deployment in version "v1" cannot be handled as a Deployment: quantities must match the regular expression '^([+-]?[0-9.]+)([eEinumkkMGTP]*[-+]?[0-9]*)$'

I believe this is actually caused by a syntax error somewhere in the yaml file but have yet to find it. I also do not believe it's due to a change I've made as I've restarted the lab several times now and continue to run into the same error.

Labels (2)
1 Solution

Accepted Solutions
Chetan_Tiwary_
Moderator
Moderator
  • 1,911 Views

Hi @dmbricke_us ,

Please check the indentation of the image key :quay.io/redhattraining/php-ssl:v1.0

While copy pasting , it gets extra space. Check the attached screenshot for your reference :

Chetan_Tiwary__0-1682581101104.png

Please rectify the same and let me know if you still have issues. 

 

 

View solution in original post

Tags (1)
3 Replies
Chetan_Tiwary_
Moderator
Moderator
  • 1,912 Views

Hi @dmbricke_us ,

Please check the indentation of the image key :quay.io/redhattraining/php-ssl:v1.0

While copy pasting , it gets extra space. Check the attached screenshot for your reference :

Chetan_Tiwary__0-1682581101104.png

Please rectify the same and let me know if you still have issues. 

 

 

Tags (1)
  • 1,829 Views

Same issue for me.  I cannot find the syntax error (extra space) in the provided yaml, but I might try a validator to check.  I'll update here if I find anything.  

UPDATE-2: I figured it out... @Chetan_Tiwary_ is right. I compared the php-http.yaml in the solutions directory to the same yaml in the labs directory and saw the added space before the image key. I wondered how that could be since I didn't add any space, BUT I walked myself through that lab again and realized that vim was adding the indetation automatically and I just hadn't noticed before. Thanks for the clue, @Chetan_Tiwary_ .

  • 130 Views

still issue not resolved 

Join the discussion
You must log in to join this conversation.