Highlighted
Flight Engineer
Flight Engineer
  • 237 Views

Trouble shoot VMs not showing up

Of 20 lab machines, 5 mysteriously do not have the VMs. 

Is there a more efficient way to fix missing VMs than reinstalling?

Labels (1)
0 Kudos
2 Replies
Highlighted
Flight Engineer
Flight Engineer
  • 148 Views

Re: Trouble shoot VMs not showing up

rht-vmctl fullreset vmname 

can work. Sometimes /etc/rht comes not configured. Fixing it doesn't always solve the problems.

scp'ing files qcows from /var/lib/libvirt/images can help but can give rise to other problems. 

scp'ing a working /usr/local/ to the new vm can help. The grading scripts can be copied to /usr/local/lib/ from content/.../.../grading-scripts/lab* 

0 Kudos
Reply
Loading...
Highlighted
Starfighter Starfighter
Starfighter
  • 137 Views

Re: Trouble shoot VMs not showing up

For those that do not have virtual machines, I would be curious as to the result of rht-pushcourse # where # is the foundation number of that system.

rht-pushcourse is the step that configures /etc/rht on the foundationX system.

Without /etc/rht properly configured, things will be broken. So I am guessing that may be the root cause. I would also confirm that "foundation-config" was properly installed as a package on that foundationX system (yum list installed foundation-config).

Also if you are focused on using "all" with rht-pushcourse and other tools, it uses the contents of /var/www/register/ on foundation0 to list the physical systems in the classroom.

rht-unregister and rht-discover can be used to manage the contents of /var/www/register/. Take a look in ClassroomTroubleshooting.txt for some examples of those tools.

--Rob
Retired Highlander of UCF (the classroom environment)

0 Kudos
Reply
Loading...
Join the discussion
You must log in to join this conversation.