Jwhite518
Flight Engineer
Flight Engineer
  • 1,799 Views

DO188 Course Problem: Ch 4.1 guided exercise

Jump to solution

I'm doing the guided exercise "Create Images with Containerfiles"

In section 3.1 we update the Containerfile with a new base image 

2023-05-11 16_50_21-DO188 - ch04s02 and 6 more pages - Work - Microsoft​ Edge.png

 and then in 4.5 we build the image, I get the following error:

"...unauthorized: access to the requested resource is not authorized"

So I can't complete the exercise. 

2023-05-11 16_47_38-GLS VM Console and 6 more pages - Work - Microsoft​ Edge.png

Labels (1)
1 Solution

Accepted Solutions
jramcast
Mission Specialist
Mission Specialist
  • 1,755 Views

I tried to replicate the problem in DO188 versions 4.10 and 4.12. It's working fine in both of them:

jramcast_0-1684137058243.png

Your problem appears to be caused by an authentication problem. Make sure that you have run the "lab start" script, which authenticates Podman into the internal image registry. 

jramcast_1-1684137624433.png

Also, from your screenshot, you seem to be using version 4.10. I'd suggest you to switch to 4.12, which is the latest release of the course.

View solution in original post

6 Replies
jramcast
Mission Specialist
Mission Specialist
  • 1,756 Views

I tried to replicate the problem in DO188 versions 4.10 and 4.12. It's working fine in both of them:

jramcast_0-1684137058243.png

Your problem appears to be caused by an authentication problem. Make sure that you have run the "lab start" script, which authenticates Podman into the internal image registry. 

jramcast_1-1684137624433.png

Also, from your screenshot, you seem to be using version 4.10. I'd suggest you to switch to 4.12, which is the latest release of the course.

DanN7
Mission Specialist
Mission Specialist
  • 1,726 Views

Just realised I had been running 4.10 too.
Is there anyway to tell/show the differences to the 4.12 version?

0 Kudos
Jwhite518
Flight Engineer
Flight Engineer
  • 1,717 Views

How do I choose course version 4.12?

0 Kudos
jramcast
Mission Specialist
Mission Specialist
  • 1,696 Views

@Jwhite518 @DanN7 on rol.redhat.com, once you navigate to the DO188 course, you should be able to use the version selector.

jramcast_1-1684308523566.png

Or you can just navigate to the URL for version 4.12  https://rol.redhat.com/rol/app/courses/do188-4.12/

 

 

0 Kudos
DanN7
Mission Specialist
Mission Specialist
  • 1,691 Views

Are there any notes on what the changs between the versions are?

0 Kudos
jramcast
Mission Specialist
Mission Specialist
  • 1,623 Views

Unfortunately, we do not include public release notes in minor releases. In brief, we updated the OpenShift version from 4.10 to 4.12, updated the Podman version to 4.2.0 (iirc), and included Podman Desktop.

We also solved several issues and implemented minor enhancements, which you can browse in JIRA:
https://training-feedback.redhat.com/browse/DO188-66?jql=project%20%3D%20DO188%20AND%20fixVersion%20...

0 Kudos
Join the discussion
You must log in to join this conversation.